FireShark - Apex on update – Incident details

All systems operational

Apex on update

Resolved
Major outage
Started over 3 years agoLasted about 18 hours

Affected

Apex Legends Work Status

Major outage from 6:11 PM to 12:13 PM

Updates
  • Resolved
    Resolved

    We just resolved the issue!

  • Identified
    Identified

    We are continuing to work on a fix for this incident.

  • Investigating
    Investigating

    We are currently investigating this incident.